[rspec-users] Ruby 1.9 - autospec loadpath problem

Adrian De la cruz lists at ruby-forum.com
Fri Jul 31 01:00:41 EDT 2009


Hi guys,

I'm getting this same error in a Ubuntu 9.04 machine.

I have Ruby 1.8.7 installed alongside Ruby 1.9.1.

When I'm on Ruby 1.9.1 and try to run the specs on a non-Rails app I get 
this error:
=======================================
/usr/local/bin/spec:19:in `load': Is a directory - 
/usr/local/lib/ruby19/gems/1.9.1/gems/rspec-rails-1.2.7.1/lib/spec 
(Errno::EISDIR)
        from /usr/local/bin/spec:19:in `<main>'
=======================================

If I switch to Ruby 1.8.7 there is no problem.

Any ideas?
-- 
Posted via http://www.ruby-forum.com/.


More information about the rspec-users mailing list