[rspec-users] any idea why spec_server gets 'cannot remove Object' error?

nbenes nathan.benes at gmail.com
Thu Jul 23 12:13:50 EDT 2009

Tim Harper wrote:
>> Have you heard of anyone that has rspec/spork/cucumber etc running under
>> cygwin, colinux, andLinux, or Ulteo Virtual Desktop. Do any of them
>> allow for fork?
> yes, yes, yes, don't know
> cygwin is slow, I would avoid it.  andLinux is a ubuntu-KDE
> distribution that uses colinux.  I use andLinux at home, and it's
> simply awesome.
> Tim
> _______________________________________________
> rspec-users mailing list
> rspec-users at rubyforge.org
> http://rubyforge.org/mailman/listinfo/rspec-users

Hey Tim, I was trying to get Spork to work on Cygwin (Yes...Cygwin is slow,
hence the desire to get everything going on a DRb).

I installed the Spork gem and setup the files for spec/cucumber just like it
said to.  However whenever I try to use it with either one it doesn't work. 
Spork starts up just fine, but then when I run:

script/spec spec --drb

It fails out on me.  I also tried doing it with autospec (and the proper
changes to the spec_helper file), but same result.

$ spork
Using RSpec
Preloading Rails environment
Loading Spork.prefork block...
Spork is ready and listening on 8989!
      3 [main] ruby 5696 C:\cygwin\bin\ruby.exe: *** fatal error - unable to
remap C:\cygwin\bin\cyggcrypt-11.dll to same address as parent(0x5390000) !=
     15 [main] ruby 3344 child_info::sync: wait failed, pid 5696, Win32
error 183
    204 [main] ruby 3344 fork: child 5696 - died waiting for dll loading,
errno 11

That's the error I get.  The 3 [main] ruby etc. line shows up when I attempt
to run my specs through it in another terminal.  The next two lines (15 and
204) show up about 5 minutes later if letting it idle.  Any idea on what
it's doing or how I can solve this?

I have rspec 1.2.8
ruby 1.8.7
rails 2.3.2

Supposedly cygwin will support the forking so something tells me this is
another issue entirely.  Any ideas?
View this message in context: http://www.nabble.com/any-idea-why-spec_server-gets-%27cannot-remove-Object%27-error--tp24162534p24629257.html
Sent from the rspec-users mailing list archive at Nabble.com.

More information about the rspec-users mailing list