[rspec-users] Cucumber + Rspec problem: Missing these required gems:

Felipe Rodrigues 02 felipero.maillist at gmail.com
Wed Jul 15 16:25:26 EDT 2009


Hi all,

I'm stuck with this error. I've just created a rails project and installed
rspec, rspec-rails, cucumber and webrat as gems. So put in my environment.rb
the following:

config.gem 'rspec-rails', :lib => false
config.gem 'rspec', :lib => false
config.gem 'cucumber'
config.gem 'webrat'

Then I shot in my shell

script/generate rspec

followed by 

script/generate cucumber

Basically following this tutorial:
http://www.ultrasaurus.com/sarahblog/2008/12/rails-2-day-3-behavior-driven-development/

So, I create a tasks_list.feature inside my features directory. Also a
tasks_list_steps.rb on my features/steps_definitions directory.

When I run "script/cucumber features" or "rake features" or even "cucumber
features" I get the following:
============================================
Missing these required gems:
rspec  >= 1.2.6
  rspec-rails  >= 1.2.6

You're running:
ruby 1.8.7.72 at /usr/bin/ruby1.8
rubygems 1.3.4 at /home/felipe/.gem/ruby/1.8, /usr/lib/ruby/gems/1.8

Run `rake gems:install` to install the missing gems.
======================================================

Any ideas about how fix that?

Thanks,

Felipe

-----
Felipe Rodrigues
http://www.fratech.net
-- 
View this message in context: http://www.nabble.com/Cucumber-%2B-Rspec-problem%3A-Missing-these-required-gems%3A-tp24505136p24505136.html
Sent from the rspec-users mailing list archive at Nabble.com.



More information about the rspec-users mailing list