[rspec-users] Cucumber ENV setting in env.rb

Andrew Premdas apremdas at gmail.com
Fri Jan 23 13:29:26 EST 2009

Have you tried setting the CUCUMBER_COLORS environment variable in your bash
config on cygwin?

2009/1/23 James Byrne <lists at ruby-forum.com>

> My original observation wrt this problem was inaccurate.  The same
> behaviour is evidenced in both my Linux and cygwin environments.
> Setting the environment variable "CUCUMBER_COLORS" in support/env.rb run
> does not alter the behaviour of that run.
> As one expects, any environment variable set within a process will not
> persist after that process terminates.  I lack the experience in either
> OS to say whether or not doing so should affect the setting process
> itself or only those processes spawned by that parent after the setting
> of the variable.
> I gathered from the cucumber documentation that the writer expected that
> setting the environment in env.rb SHOULD have some effect.  However, I
> cannot say if that expectation was valid or not.
> I am not experiencing any problems with displaying colours or text
> enhancements (within the limited ANSI palette) in either environment.
> --
> Posted via http://www.ruby-forum.com/.
> _______________________________________________
> rspec-users mailing list
> rspec-users at rubyforge.org
> http://rubyforge.org/mailman/listinfo/rspec-users
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://rubyforge.org/pipermail/rspec-users/attachments/20090123/a1250134/attachment.html>

More information about the rspec-users mailing list