[rspec-users] Cucumber ENV setting in env.rb

aslak hellesoy aslak.hellesoy at gmail.com
Fri Jan 23 09:34:08 EST 2009

On Fri, Jan 23, 2009 at 3:20 PM, James Byrne <lists at ruby-forum.com> wrote:

> My original observation wrt this problem was inaccurate.  The same
> behaviour is evidenced in both my Linux and cygwin environments.
> Setting the environment variable "CUCUMBER_COLORS" in support/env.rb run
> does not alter the behaviour of that run.

Updated docs: http://wiki.github.com/aslakhellesoy/cucumber/console-colours

> As one expects, any environment variable set within a process will not
> persist after that process terminates.  I lack the experience in either
> OS to say whether or not doing so should affect the setting process
> itself or only those processes spawned by that parent after the setting
> of the variable.
> I gathered from the cucumber documentation that the writer expected that
> setting the environment in env.rb SHOULD have some effect.  However, I
> cannot say if that expectation was valid or not.
> I am not experiencing any problems with displaying colours or text
> enhancements (within the limited ANSI palette) in either environment.
> --
> Posted via http://www.ruby-forum.com/.
> _______________________________________________
> rspec-users mailing list
> rspec-users at rubyforge.org
> http://rubyforge.org/mailman/listinfo/rspec-users

Aslak (::)
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://rubyforge.org/pipermail/rspec-users/attachments/20090123/f3bab85d/attachment.html>

More information about the rspec-users mailing list