[rspec-users] App can't start on production server due to RSpec missing

Jonathan Linowes jonathan at parkerhill.com
Sun Jan 18 09:47:28 EST 2009

On Jan 17, 2009, at 2:14 PM, Mark Wilden wrote:

> On Sat, Jan 17, 2009 at 5:42 AM, Jonathan Linowes  
> <jonathan at parkerhill.com> wrote:
> On Jan 16, 2009, at 4:15 PM, Fernando Perez wrote:
> I run rspec on my dev machine, but obviously not on my production
> machine, what would be the nicest way to handle such scenario? At the
> Actually, I run specs on my production machine,
>  cap deploy:spec
> :)
> since its a different platform from my development,
> especially on point releases of the app
> Umm, how do you handle that whole rake db:test:prepare thing?
> ///ark
> _______________________________________________
> rspec-users mailing list
> rspec-users at rubyforge.org
> http://rubyforge.org/mailman/listinfo/rspec-users

I copy the schema from production, the server doesnt have a  
development database.
also, my opts default to --format html so i can browse to the results
 From my Capfile

   task :spec, :roles => :app do
     run "cd #{current_path} && rake db:test:prepare  
RAILS_ENV=production" # copy schema from production rather than  
     run "cd #{current_path} && rake spec RAILS_ENV=production  

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://rubyforge.org/pipermail/rspec-users/attachments/20090118/16c1a193/attachment.html>

More information about the rspec-users mailing list