[rspec-users] Which webrat gem should be used?

James Byrne lists at ruby-forum.com
Fri Jan 16 11:59:27 EST 2009


Aslak Hellesøy wrote:
> If you're on Rails and use RSpec matchers, the latest official
> webrat 0.3.4 gem is broken. It doesn't contain the webrat/rspec-rails.rb
> file (a packaging bug).
> 

If you feel adventurous then, after installing cucumber-0.3.4, you could 
create a file with this content:

#bod
require "webrat/core/matchers"

Spec::Runner.configure do |config|
  config.include(Webrat::Matchers, :type => :controller)
  config.include(Webrat::Matchers, :type => :helper)
  config.include(Webrat::Matchers, :type => :view)
end
#eod

and save it (with the appropriate ownership and permissions for your OS 
of course) as:

/usr/lib/ruby/gems/1.8/gems/webrat-0.3.4/lib/webrate/rspec-rails.rb

Works for me but, as always, YMMV.

-- 
Posted via http://www.ruby-forum.com/.


More information about the rspec-users mailing list