[rspec-users] Missing model attribute in cucumber test

James Byrne lists at ruby-forum.com
Wed Jan 14 13:56:57 EST 2009

James Byrne wrote:

> Then I see this error:
>     And the user named "newuser" is an administrator     #
> features/app/models/users/step_definitions/user_steps.rb:24
>       undefined method `user_administrator' for #<User:0x2ac26fa83e80>
> (NoMethodError)
>       /usr/lib64/ruby/gems/1.8/gems/activerecord-2.2.2/lib/active_record/attribute_methods.rb:260:in
> `method_missing'
>       ./features/app/models/users/step_definitions/user_steps.rb:26:in
> `And /user named "(.*)" is an administrator/'
>       features/app/models/users/user.feature:29:in `And the user named
> "newuser" is an administrator'
> Have I misspelled something somewhere and just cannot see it?  what is
> causing this?

I have changed the type to string and get the same error.  I have 
changed the attribute name to useradministrator and still get the same 
Posted via http://www.ruby-forum.com/.

More information about the rspec-users mailing list