[rspec-users] Cucumber namespace problem

Emmanuel Pinault seatmanu at gmail.com
Fri Jan 2 13:20:12 EST 2009


I am having an issue with Cucumber where I am writing in one files  
some steps where rspec matcher do not seem to be accessible.

So I have a file with my steps  written like this

require 'steputils'

Given "some step description 1 " do

Given "some step description 2 that is slighty different for better  
readability "  do

and in steputils I have

class Steputils

	def self.post(args)
		args.should_not be_empty

But the code breaks when trying to run args.should_not be_empty that  
are valid rspec matchers.. Seems like it is not recognizing it. I  
tried to include Cucumber and Spec as part of my class
but still not working. Any idea what I need to do to make it work?  
This will help refactoring some of the steps that may have similar code

Also, is there a way to see all the existing step using the cucumber  
methods? because when you have a lot it would be nice to have a way to  
describe them for documentation purpose (like  Rake does for task)



More information about the rspec-users mailing list