[rspec-users] RSpec with edge rails (2.3 RC1)

George Anderson george at benevolentcode.com
Wed Feb 25 16:53:28 EST 2009


I pulled both repos and tried 'rake gem' but got 'permission denied'
'sudo rake gem' worked:

~/work/rspec (master) $ rake gem
(in /Users/george/work/rspec)
/opt/local/lib/ruby/gems/1.8/gems/rake-0.8.3/lib/rake/gempackagetask.rb:13:Warning:
Gem::manage_gems is deprecated and will be removed on or after March
2009.
  Successfully built RubyGem
  Name: rspec
  Version: 1.1.99.9
  File: rspec-1.1.99.9.gem
mv rspec-1.1.99.9.gem pkg/rspec-1.1.99.9.gem
rake aborted!
Permission denied - rspec-1.1.99.9.gem or pkg/rspec-1.1.99.9.gem

(See full trace by running task with --trace)
~/work/rspec (master) $ sudo rake gem
(in /Users/george/work/rspec)
/opt/local/lib/ruby/gems/1.8/gems/rake-0.8.3/lib/rake/gempackagetask.rb:13:Warning:
Gem::manage_gems is deprecated and will be removed on or after March
2009.
  Successfully built RubyGem
  Name: rspec
  Version: 1.1.99.9
  File: rspec-1.1.99.9.gem
mv rspec-1.1.99.9.gem pkg/rspec-1.1.99.9.gem

same with 'rake install_gem' (required sudo)


After re-running "script/generate rspec" it still fails:

it:pdf_revisions!stc_partner_plan> spec spec/models/html_page_spec.rb
/opt/local/lib/ruby/site_ruby/1.8/rubygems.rb:636:in
`report_activate_error': RubyGem version error: rspec(1.1.99.9 not =
1.1.11.1) (Gem::LoadError)
	from /opt/local/lib/ruby/site_ruby/1.8/rubygems.rb:141:in `activate'
	from /opt/local/lib/ruby/site_ruby/1.8/rubygems.rb:165:in `activate'
	from /opt/local/lib/ruby/site_ruby/1.8/rubygems.rb:164:in `each'
	from /opt/local/lib/ruby/site_ruby/1.8/rubygems.rb:164:in `activate'
	from /opt/local/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:35:in
`require'
	from /opt/local/lib/ruby/gems/1.8/gems/activesupport-2.3.0/lib/active_support/dependencies.rb:158:in
`require'
	from ./spec/models/../spec_helper.rb:6
	from /opt/local/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:31:in
`gem_original_require'
	 ... 7 levels...
	from /opt/local/lib/ruby/gems/1.8/gems/rspec-1.1.99.9/lib/spec/runner/command_line.rb:9:in
`run'
	from /opt/local/lib/ruby/gems/1.8/gems/rspec-1.1.99.9/bin/spec:4
	from /opt/local/bin/spec:19:in `load'
	from /opt/local/bin/spec:19

I wish I had better news to report.

Thanks for your help,

/g

--

George Anderson

BenevolentCode LLC
O: (410) 461-7553
C: (410) 218-5185

george at benevolentcode.com

On Wed, Feb 25, 2009 at 4:11 PM, David Chelimsky <dchelimsky at gmail.com> wrote:
> On Wed, Feb 25, 2009 at 2:35 PM, George Anderson
> <george at benevolentcode.com> wrote:
>> >From David: > We're up to 1.1.99.9 now - have you tried that?
>>
>> Sorry, yes, I meant 1.1.99.1.
>>
>> ~/work/rspec (master) $ gem list rspec
>>
>> *** LOCAL GEMS ***
>>
>> rspec (1.1.99.9)
>> rspec-rails (1.1.99.9)
>>
>>
>> This is what I did:
>>
>> cloned: git://github.com/dchelimsky/rspec.git
>> rake gem
>> rake install_gem
>>
>> cloned: git://github.com/dchelimsky/rspec-rails.git
>> rake gem
>> rake install_gem
>
> OK - I know what the cause might be here. Do me a favor and repeat
> that process please (using pull instead of clone - I just pushed some
> code to github) and let me know if you still have a problem.
>
> Thx
>
>>
>> In my project:
>> script/generate rspec
>>
>> #      modified:   lib/tasks/rspec.rake
>> #       modified:   script/autospec
>> #       modified:   spec/spec_helper.rb
>>
>>
>> spec spec/models/html_page_spec.rb
>> /opt/local/lib/ruby/site_ruby/1.8/rubygems.rb:636:in
>> `report_activate_error': RubyGem version error: rspec(1.1.99.9 not =
>> 1.1.11.1) (Gem::LoadError)
>>        from /opt/local/lib/ruby/site_ruby/1.8/rubygems.rb:141:in `activate'
>>        from /opt/local/lib/ruby/site_ruby/1.8/rubygems.rb:165:in `activate'
>>        from /opt/local/lib/ruby/site_ruby/1.8/rubygems.rb:164:in `each'
>>        from /opt/local/lib/ruby/site_ruby/1.8/rubygems.rb:164:in `activate'
>>        from /opt/local/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:35:in
>> `require'
>>        from /opt/local/lib/ruby/gems/1.8/gems/activesupport-2.3.0/lib/active_support/dependencies.rb:158:in
>> `require'
>>        from ./spec/models/../spec_helper.rb:6
>>        from /opt/local/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:31:in
>> `gem_original_require'
>>         ... 7 levels...
>>        from /opt/local/lib/ruby/gems/1.8/gems/rspec-1.1.99.9/lib/spec/runner/command_line.rb:9:in
>> `run'
>>        from /opt/local/lib/ruby/gems/1.8/gems/rspec-1.1.99.9/bin/spec:4
>>        from /opt/local/bin/spec:19:in `load'
>>        from /opt/local/bin/spec:19
>>
>>
>> spec_helper.rb (line 6)
>> require 'spec/rails'
>>
>> $ cat spec_helper.rb
>> ENV["RAILS_ENV"] = "test"
>> require File.expand_path(File.dirname(__FILE__) + "/../config/environment")
>> require 'spec'
>> require 'spec/rails'
>>
>> Spec::Runner.configure do |config|
>>  config.use_transactional_fixtures = true
>>  config.use_instantiated_fixtures  = false
>>  config.fixture_path = RAILS_ROOT + '/spec/fixtures/'
>> end
>>
>>
>> So it looks as if I need to update the dependency version for rspec to
>> be 1.1.99.9, but I'm not sure where I need to do that.
>>
>> Thanks,
>>
>> /g
>>
>> --
>>
>> George Anderson
>>
>> BenevolentCode LLC
>> O: (410) 461-7553
>> C: (410) 218-5185
>>
>> george at benevolentcode.com
>>
>> On Wed, Feb 25, 2009 at 2:58 PM, Yi Wen <hayafirst at gmail.com> wrote:
>>> I have edge rails along with RSpec 1.1.99. works fine. What errors do you
>>> get?
>>>
>>> On Wed, Feb 25, 2009 at 1:24 PM, George Anderson <george at benevolentcode.com>
>>> wrote:
>>>>
>>>> Hi,
>>>>
>>>> I'm failing miserably to get RSpec running with edge rails (2.3 RC1).
>>>> I've tried building/installing the 1.1.99.1 gems from David's git
>>>> repos (http://github.com/dchelimsky/rspec-rails and
>>>> http://github.com/dchelimsky/rspec), but no luck.
>>>>
>>>> I realize "releases with a 4th partial [are] interim (unofficial)
>>>> release[s]" and I should use them at my own risk.  Could someone
>>>> kindly provide fairly explicit instructions for getting RSpec running
>>>> with 2.3 RC1?  I suspect I'm making things more difficult than they
>>>> are.
>>>>
>>>> If needed I can post error messages, but I'm not sure I'm on the right
>>>> path to start with, so I don't think that would be helpful.
>>>>
>>>> Thanks,
>>>>
>>>> /g
>>>>
>>>> --
>>>>
>>>> George Anderson
>>>>
>>>> BenevolentCode LLC
>>>> O: (410) 461-7553
>>>> C: (410) 218-5185
>>>>
>>>> george at benevolentcode.com
>>>> _______________________________________________
>>>> rspec-users mailing list
>>>> rspec-users at rubyforge.org
>>>> http://rubyforge.org/mailman/listinfo/rspec-users
>>>
>>>
>>> _______________________________________________
>>> rspec-users mailing list
>>> rspec-users at rubyforge.org
>>> http://rubyforge.org/mailman/listinfo/rspec-users
>>>
>> _______________________________________________
>> rspec-users mailing list
>> rspec-users at rubyforge.org
>> http://rubyforge.org/mailman/listinfo/rspec-users
>>
> _______________________________________________
> rspec-users mailing list
> rspec-users at rubyforge.org
> http://rubyforge.org/mailman/listinfo/rspec-users
>


More information about the rspec-users mailing list