[rspec-users] Which webrat gem should be used?

Mike Frawley lists at ruby-forum.com
Wed Feb 18 22:24:05 EST 2009


I'm having trouble getting cucumber working.  I have webrat 0.4.1 
installed, but still get the error:

    /Library/Ruby/Site/1.8/rubygems/custom_require.rb:31:in 
`gem_original_require': no such file to load -- spec/rails 
(MissingSourceFile)

Aslak Hellesøy wrote:
> If you're on Rails and use RSpec matchers, the latest official webrat 
> 0.3.4
> gem is broken. It doesn't contain the webrat/rspec-rails.rb file (a
> packaging bug).
> 
> aslakhellesoy-webrat (0.3.2.2) works fine.

I tried replacing line 10 in support/env from `require 'webrat'` to:

    require 'aslakhellesoy-webrat'

and:

    gem 'aslakhellesoy-webrat', '0.3.2.2'

But neither worked.  (If using `gem` is the wrong way to load a 
particular gem in a rails project please point me out the correct way to 
me :)

I also just tried uninstalling the 'webrat' gem, leaving only 
'aslakhellesoy-webrat', and changed line 10 back to `require 'webrat'`, 
but still have get the error.

Thanks,
Mike ˙∆˚
-- 
Posted via http://www.ruby-forum.com/.


More information about the rspec-users mailing list