[rspec-users] [cucumber] can't use 'visit' except with `rake features`

r_j_h_box-sf at yahoo.com r_j_h_box-sf at yahoo.com
Mon Feb 16 01:16:15 EST 2009


I'm running it like so:

$ cucumber features/

I've also tried using 

  --require config/boot.rb --require features
  --require config/environment.rb

and now, I've tried with 

  --require lib --require features features/  (nope)

  --require features --require lib features/  (yes!)

Shazaaaayam!  Okay, thank you for the hint.  Lessee, then for autospec... aha.  Yep.  cucumber.yml, check.  Added these working args to the autotest and autotest-all config, working well now.

Okay, updated the wiki page to add some details.  These work for me now.  

http://wiki.github.com/aslakhellesoy/cucumber/ruby-on-rails


I'd appreciate a review of this stuff I've added - hopefully it provides more help than harm to others in my situation. :)

Thanks,

Randy



----- Original Message ----
> From: James Byrne <lists at ruby-forum.com>
> To: rspec-users at rubyforge.org
> Sent: Sunday, February 15, 2009 6:39:25 PM
> Subject: Re: [rspec-users] [cucumber] can't use 'visit' except with `rake features`
> 
> unknown wrote:
> 
> how are you invoking cucumber from the command line?
> 
> -- 
> Posted via http://www.ruby-forum.com/.
> _______________________________________________
> rspec-users mailing list
> rspec-users at rubyforge.org
> http://rubyforge.org/mailman/listinfo/rspec-users



More information about the rspec-users mailing list