[rspec-users] redirects while using subdomains not working in 4.1

Zach Dennis zach.dennis at gmail.com
Fri Feb 6 10:21:39 EST 2009

On Fri, Feb 6, 2009 at 10:20 AM, Zach Dennis <zach.dennis at gmail.com> wrote:
> On Fri, Feb 6, 2009 at 9:12 AM, Tom Hoen <lists at ruby-forum.com> wrote:
>> Zach Dennis wrote:
>>> Were you using one of my branches, and was it working for you?
>>> I just pulled down the latest webrat and installed it on a project
>>> that uses subdomains, and all of the features are still passing.
>> Zach -
>> I was using this fork:
>> http://github.com/zdennis/webrat/tree/make_current_url_fully_qualified,
> I am pretty certain that the change in this branch never got committed
> to webrat. The ticket is still open:
>   http://webrat.lighthouseapp.com/projects/10503/tickets/140-current_url-should-be-fully-qualified
> dstar opened a ticket which is related, as in it requires that all
> urls are fully qualified, I don't believe it has been committed either
> look back at it:
>  http://webrat.lighthouseapp.com/projects/10503/tickets/147-linkabsolute_href-is-broken
> I haven't tried out dstar's patch, but I believe we solve the same
> problem, we just do it at different points.

Correction -- I believe his problem forces the problem in my ticket to
be solved. I don't know if my patch solves his problem.

> Perhaps Bryan or Josh could look at these. In the meantime I have
> pushed an updated branch which includes all of webrat 4.1. Hopefully
> in the meantime this will solve the issue for you:
>   http://github.com/zdennis/webrat/tree/make_current_url_fully_qualified-4.1
>> and it was working. I moved to the most recent version of webrat, hoping
>> to use set_hidden_field, which did not seem to be in your fork.
>> I would love to help figure out why it is not working for me, but I just
>> don't know enough about ruby/rails/webrat/mechanize etc yet. Though I
>> will try to track down what is going wrong, it is unlikely I will find
>> it.
>> First, I am going to make sure that I am current on all of the pieces. I
>> develop on a Vista machine, but run tests on Ubuntu running in VMWare.
>> It may be that one of the dependencies is out of date (rspec, cucumber,
>> webrat, etc.).
>> Currently, I have the following installed:
>> rspec (1.1.12, 1.1.4)
>> rspec-rails (1.1.12)
>> webrat (0.4.0)
>> hpricot (0.6.161)
>> cucumber (0.1.16, 0.1.14, 0.1.12)
>> Rails 2.1.2
>> The first test that fails is a simple login. After successfully
>> completing the login (filling in login and password and clicking login),
>> the user is redirected to their personal page. At this point, Cucumber
>> is seeing the response as "You are being redirected" instead of
>> following the redirect. The message contains the correct redirect url,
>> so I know the login is working.
>> The first step of my login feature is the following:
>> visit login_path(:host => "rpems.test")
>> Any advice you can give would be greatly appreciated.
>> Tom
>> --
>> Posted via http://www.ruby-forum.com/.
>> _______________________________________________
>> rspec-users mailing list
>> rspec-users at rubyforge.org
>> http://rubyforge.org/mailman/listinfo/rspec-users
> --
> Zach Dennis
> http://www.continuousthinking.com
> http://www.mutuallyhuman.com

Zach Dennis

More information about the rspec-users mailing list