[rspec-users] [RSpec] rcov and/or rexml bug?

Fernando Perez lists at ruby-forum.com
Mon Feb 2 16:30:01 EST 2009


Hi,

Running: Ruby 1.8.7 p72, RSpec 1.1.12 and rcov 0.8.1.2.0, I get the
following error message with $ rake spec:rcov

--
/usr/local/ruby1.8.7//lib/ruby/1.8/rexml/formatters/pretty.rb:131:in
`[]': no implicit conversion from nil to integer (TypeError)
        from
/usr/local/ruby1.8.7//lib/ruby/1.8/rexml/formatters/pretty.rb:131:in
`wrap'
        from
/usr/local/ruby1.8.7//lib/ruby/1.8/rexml/formatters/pretty.rb:131:in
`wrap'
        from
/usr/local/ruby1.8.7//lib/ruby/1.8/rexml/formatters/pretty.rb:90:in
`write_text'
        from
/usr/local/ruby1.8.7//lib/ruby/1.8/rexml/formatters/default.rb:50:in
`write'
        from
/usr/local/ruby1.8.7//lib/ruby/1.8/rexml/formatters/pretty.rb:75:in
`write_element'
        from
/usr/local/ruby1.8.7//lib/ruby/1.8/rexml/formatters/pretty.rb:73:in
`each'
        from
/usr/local/ruby1.8.7//lib/ruby/1.8/rexml/formatters/pretty.rb:73:in
`write_element'
        from
/usr/local/ruby1.8.7//lib/ruby/1.8/rexml/formatters/default.rb:31:in
`write'
        from
/usr/local/ruby1.8.7//lib/ruby/1.8/rexml/formatters/pretty.rb:75:in
`write_element'
        from
/usr/local/ruby1.8.7//lib/ruby/1.8/rexml/formatters/pretty.rb:73:in
`each'
        from
/usr/local/ruby1.8.7//lib/ruby/1.8/rexml/formatters/pretty.rb:73:in
`write_element'
        from
/usr/local/ruby1.8.7//lib/ruby/1.8/rexml/formatters/default.rb:31:in
`write'
        from
/usr/local/ruby1.8.7//lib/ruby/1.8/rexml/formatters/pretty.rb:117:in
`write_document'
        from
/usr/local/ruby1.8.7//lib/ruby/1.8/rexml/formatters/pretty.rb:111:in
`each'
        from
/usr/local/ruby1.8.7//lib/ruby/1.8/rexml/formatters/pretty.rb:111:in
`write_document'
        from
/usr/local/ruby1.8.7//lib/ruby/1.8/rexml/formatters/default.rb:28:in
`write'
        from /usr/local/ruby1.8.7//lib/ruby/1.8/rexml/document.rb:195:in
`write'
        from (eval):93:in `pretty'
        from
/usr/local/ruby1.8.7/lib/ruby/gems/1.8/gems/rcov-0.8.1.2.0/lib/rcov/report.rb:1003:in
`create_file'
        from
/usr/local/ruby1.8.7/lib/ruby/gems/1.8/gems/rcov-0.8.1.2.0/lib/rcov/report.rb:708:in
`execute'
        from
/usr/local/ruby1.8.7/lib/ruby/gems/1.8/gems/rcov-0.8.1.2.0/lib/rcov/report.rb:125:in
`each'
        from
/usr/local/ruby1.8.7/lib/ruby/gems/1.8/gems/rcov-0.8.1.2.0/lib/rcov/report.rb:125:in
`each_file_pair_sorted'
        from
/usr/local/ruby1.8.7/lib/ruby/gems/1.8/gems/rcov-0.8.1.2.0/lib/rcov/report.rb:707:in
`execute'
        from
/usr/local/ruby1.8.7/lib/ruby/gems/1.8/gems/rcov-0.8.1.2.0/lib/rcov.rb:640:in
`dump_coverage_info'
        from
/usr/local/ruby1.8.7/lib/ruby/gems/1.8/gems/rcov-0.8.1.2.0/lib/rcov.rb:640:in
`each'
        from
/usr/local/ruby1.8.7/lib/ruby/gems/1.8/gems/rcov-0.8.1.2.0/lib/rcov.rb:640:in
`dump_coverage_info'
        from
/usr/local/ruby1.8.7/lib/ruby/gems/1.8/gems/rcov-0.8.1.2.0/bin/rcov:421
rake aborted!
--

Anyone ran into that? Should I downgrade my Ruby version to have it
work? I previously updated it to its latest release hoping bugs would be
fixed.
-- 
Posted via http://www.ruby-forum.com/.


More information about the rspec-users mailing list