[rspec-users] more verbosity for be_an?

David Chelimsky dchelimsky at gmail.com
Wed Dec 30 15:19:00 EST 2009


On Wed, Dec 30, 2009 at 1:33 PM, rogerdpack <rogerpack2005 at gmail.com> wrote:

> before I hack up a patch for it.  Would a patch to change
>
> "expected Fixnum to be a kind of Fixnum"
>
> to
>
> "expected Fixnum to be a kind of Fixnum (is a Class)"
>
> or possibly
>
> "expected Fixnum to be a kind of Fixnum (is a Class, Module, Object,
> Kernel, BasicObject)"
>
>
> have any chance of being accepted?
>

Probably not with that exact wording, but if you feel the message is not
telling you what you need to know, I'm open to other ideas.

What about something like:

  expected #<Class:2158174640> => Fixnum to be a kind of Fixnum

That is more aligned with other failure messages. WDYT?



> Thanks.
> -r
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://rubyforge.org/pipermail/rspec-users/attachments/20091230/4ce1acc0/attachment.html>


More information about the rspec-users mailing list