[rspec-users] more verbosity for be_an?

rogerdpack rogerpack2005 at gmail.com
Wed Dec 30 14:33:58 EST 2009


before I hack up a patch for it.  Would a patch to change

"expected Fixnum to be a kind of Fixnum"

to

"expected Fixnum to be a kind of Fixnum (is a Class)"

or possibly

"expected Fixnum to be a kind of Fixnum (is a Class, Module, Object,
Kernel, BasicObject)"


have any chance of being accepted?
Thanks.
-r


More information about the rspec-users mailing list