[rspec-users] Help with some basics

Andrew Timberlake andrew at andrewtimberlake.com
Thu Apr 30 23:21:54 EDT 2009


On Thu, Apr 30, 2009 at 10:04 PM, David Chelimsky <dchelimsky at gmail.com> wrote:
> On Thu, Apr 30, 2009 at 2:55 PM, Andrew Timberlake
> <andrew at andrewtimberlake.com> wrote:
>> It gives me the same error when I run
>> rake spec
>> spec specs/
>> or
>> autospec
>>
>> It also gives the same error with specs like
>> it { should_not be_nil }
>> and
>> it { should respond_to(:name) }
>
> Those are internal to rspec and I can assure you they have descriptions.
>
> I'm mystified. Anybody else on this list have a similar experience?
>
>

Managed to find the problem, the class ProductTemplate wasn't being
loaded so "it" wasn't working on an object.
The error is not very useful in this situation but I'm moving forward again.

Thanks for the help

Andrew Timberlake
http://ramblingsonrails.com
http://www.linkedin.com/in/andrewtimberlake

"I have never let my schooling interfere with my education" - Mark Twain


More information about the rspec-users mailing list