[rspec-users] Noob question

WJSimacek wayne.simacek at gmail.com
Tue Apr 28 17:02:56 EDT 2009


There's about 3 more gems you need to install. RSpec, RSpec-rails and
WebRat. There's also a great introductory article I found on-line at
http://blog.rubyyot.com/2009/01/chores-a-test-driven-website/

I'm only half-step ahead of you and feel your pain.
Good luck,
Wayne

On Apr 28, 12:47 pm, "Sophie \(itsme213\)" <itsme... at hotmail.com>
wrote:
> Just getting started with cucumber on Mac 10.5.6.
>
> I have the default Ruby install (1.8). I'm not using Rails. I did a
>   gem update cucumber
> and now have cucumber-0.3.1 in my gems.
>
> I also did a
>   git clone
> and have a repo with cucumber 0.3.2.
>
> When I cd into my cucumber (git) directory and do:
>   cucumber features
> I get
> /System/Library/Frameworks/Ruby.framework/Versions/1.8/usr/lib/ruby/1.8/rubygems/custom_require.rb:27:in
> `gem_original_require': no such file to load -- spec/expectations
> (LoadError)
> Failed to load ./cucumber/examples/selenium_webrat/features/support/env.rb
> from
> /System/Library/Frameworks/Ruby.framework/Versions/1.8/usr/lib/ruby/1.8/rubygems/custom_require.rb:27:in
> `polyglot_original_require'
>  from /Library/Ruby/Gems/1.8/gems/polyglot-0.2.5/lib/polyglot.rb:54:in
> `require'
>  from ./cucumber/examples/selenium_webrat/features/support/env.rb:1
>
> ...
>
> Looks like I need a bunch more stuff than what the gem installs. Where can I
> find out what to install?
>
> Thanks!
>
> _______________________________________________
> rspec-users mailing list
> rspec-us... at rubyforge.orghttp://rubyforge.org/mailman/listinfo/rspec-users


More information about the rspec-users mailing list