[rspec-users] Background and scenario outline interaction

wolfmanjm wolfmanjm at gmail.com
Mon Apr 27 17:47:33 EDT 2009


Ok there is a different bug with 0.3.0, I'll work up a gist, but it
seems that background with scenario outline now has background  run
before the Before hook, or maybe the before hook is not being run. The
docs say background runs after the before hook.

I need to debug further to see what is actually happening

On Apr 27, 5:11 am, Andrew Premdas <aprem... at gmail.com> wrote:
> Is this with 0.3.0? If not this might have been recently fixed as I reported
> a similar bug recently
>
> 2009/4/24 Jim Morris <wolfma... at gmail.com>
>
> > Hi,
>
> > I was surprised by this so I suspect it may be a bug.
>
> > I have a Scenario Outline, and a Background in my Feature and nothing
> > else,
>
> > The Background got executed 1 more time than expected.
>
> > Details are the Scenario Outline had 4 entries in the table, so I
> > expected 4 scenarios to get executed, and the Background to get
> > executed before each Scenario.
>
> > What happened was the Background got executed once initially, then
> > once for each entry on the outline table, the After scenario hook got
> > correctly executed after each of the 4 scenarios, but not after the
> > first Background (understandably as there was no scenario executed).
>
> > Is this a bug or feature ;)
> > _______________________________________________
> > rspec-users mailing list
> > rspec-us... at rubyforge.org
> >http://rubyforge.org/mailman/listinfo/rspec-users
>
>
>
> _______________________________________________
> rspec-users mailing list
> rspec-us... at rubyforge.orghttp://rubyforge.org/mailman/listinfo/rspec-users


More information about the rspec-users mailing list