[rspec-users] Problems running features with Textmate Cucumber bundle

Rick DeNatale rick.denatale at gmail.com
Mon Apr 27 08:13:23 EDT 2009


On Sun, Apr 26, 2009 at 11:38 PM, Ben Mabey <ben at benmabey.com> wrote:
> Rick DeNatale wrote:
>>
>> I finally plunked down for the beta RSpec bundle and I'm working
>> through the initial example.  Although I'm a fairly experienced RSpec
>> user, I'm stlll learning new tricks.
>>
>> Anyway,  I'm going though the mastermind example, and everything is
>> going well, except that I decided to also try out the Textmate bundle
>> for Cucumber.  I decided to use Ben Mabey's fork on github since it
>> seems to be the most evolved.
>>
>> When I try to run a feature with cmd-R, instead of actually running I
>> see something like:
>>
>> Running: cucumber
>> /Users/rick/mastermind/features/codebreaker_starts_game.feature
>> --format=html
>> false
>>
>> Cucumber runs fine from bash.
>>
>> Am I missing some setup?
>>
>>
>
> Hmm.. that is odd. What version of Cucumber are you using?  When you run
> that exact command from the shell does it output the HTML report?

I was runing 0.3.0 upgrading to 0.3.1 has the same result BUT

If I run that exact command

$ /Users/rick/mastermind/features/codebreaker_starts_game.feature --format=html
-bash: /Users/rick/mastermind/features/codebreaker_starts_game.feature:
Permission denied


It's trying to run the feature as an executable directly it's not
running the cucumber executable!

Why it be doin dat?

-- 
Rick DeNatale

Blog: http://talklikeaduck.denhaven2.com/
Twitter: http://twitter.com/RickDeNatale
WWR: http://www.workingwithrails.com/person/9021-rick-denatale
LinkedIn: http://www.linkedin.com/in/rickdenatale


More information about the rspec-users mailing list