[rspec-users] But rspec can not be found

Kerstin Geiling lists at ruby-forum.com
Wed Apr 22 09:51:45 EDT 2009


> On 18 Apr 2009, at 05:08, David Chelimsky wrote:
>> I'm not sure that requiring environment.rb is the right solution
>> because it will be loaded no matter what rake task is invoked, and
>> that is clearly not the intent for all rake tasks.
>>
>> I hate to go back to the ugly mess that was there to add either the
>> plugin or installed gem path to the load path, but that may be the
>> only reasonable alternative.
>>
>> Any other ideas?

Hi,

actually I had the same problems Tom had, 3 weeks ago, but thought that 
it might be somehow my fault that neither vendor/gems nor vendor/plugin 
worked with rspec-rails 1.2.2 (or now 1.2.4).

I solved it now using the old task file from rspec-rails 1.2.0 and it 
works.

I found it really puzzling to get an error message like:

********************************************************************************
*  You are trying to run an rspec rake task defined in
*  .../lib/tasks/rspec.rake,
*  but rspec can not be found in vendor/gems, vendor/plugins or system 
gems.
*******************************************************************************

because I tried to install rspec-rails and rspec in both ways.

Thanks to Tom for making this issue public!

@David: I followed the instructions in the beta "The Rspec Book" ebook, 
where vendor/gems and vendor/plugins are described for using rspec in 
rails

Cheers,
Kerstin
-- 
Posted via http://www.ruby-forum.com/.


More information about the rspec-users mailing list