[rspec-users] various results from same test

Jeremiah Heller jeremiah.heller at gmail.com
Tue Apr 14 07:32:53 EDT 2009


I've read on the 'Cucumber Backgrounder' page that running cuc via  
rake, command line and autotest could give different results but I  
seem to get different results depending on the path I pass cucumber  
and am not sure what's going on. I would be grateful for any help or  

There's a fresh rails app with features/admin_management/ 
{crud_admins.feature,crud_admins_steps.rb} and the other default  
files. webrat, rspec(-rails) and cucumber are installed as plugins  
from their respective master branches (as of a couple hours ago) - I  
had them installed as gems initially but now gems are all uninstalled  
and only plugins reside.

crud_admins.feature; just has a single step:
	Scenario: Create an admin user
	Given I can see the form to create an admin user

crud_admins_steps.rb; just has a single step-def:
	Given "I can see the form to $action a(n)? $controller $domain" do | 
action, _, controller, domain|
	  visit path_to("#{action} #{controller} #{domain}")

If I run `script/cucumber features/admin_management/ 
crud_admins.feature`; I see:
	undefined method `visit' for

If I run `script/cucumber features`; I see:
	No route matches "/admin/users/create"

which is what I expect.

There are no migrations yet; could that be an/the issue?

- Jeremiah

More information about the rspec-users mailing list