[rspec-users] (MissingSourceFile) no such file to load -- spec/expectations/differs/default

AndreXP andre.x.pretorius at gmail.com
Tue Apr 14 05:00:50 EDT 2009


Hi All,

This morning I did a "gem update" which installed "rspec-1.2.4" and when I
run my cucumber "rake features" command I got the following:

c:/ruby/lib/ruby/site_ruby/1.8/rubygems.rb:142:in `activate': can't activate
rspec (= 1.2.2, runtime), already activated rspec-1.2.4
 (Gem::Exception)
        from c:/ruby/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:31:in
`polyglot_original_require'
        from
c:/ruby/lib/ruby/gems/1.8/gems/polyglot-0.2.5/lib/polyglot.rb:54:in
`require'
        from
c:/ruby/lib/ruby/gems/1.8/gems/activesupport-2.3.2/lib/active_support/dependencies.rb:156:in
`require'
        from
c:/ruby/lib/ruby/gems/1.8/gems/activesupport-2.3.2/lib/active_support/dependencies.rb:521:in
`new_constants_in'
        from
c:/ruby/lib/ruby/gems/1.8/gems/activesupport-2.3.2/lib/active_support/dependencies.rb:156:in
`require'
        from
c:/ruby/lib/ruby/gems/1.8/gems/cucumber-0.2.3/bin/../lib/cucumber/cli/main.rb:92:in
`enable_diffing'
        from
c:/ruby/lib/ruby/gems/1.8/gems/cucumber-0.2.3/bin/../lib/cucumber/cli/main.rb:35:in
`execute!'
        from
c:/ruby/lib/ruby/gems/1.8/gems/cucumber-0.2.3/bin/../lib/cucumber/cli/main.rb:20:in
`execute'
        from c:/ruby/lib/ruby/gems/1.8/gems/cucumber-0.2.3/bin/cucumber:6
rake aborted!
Command failed with status (1): [c:/ruby/bin/ruby -I
"c:/ruby/lib/ruby/gems...]

Then I run the "Gem clean" command which removed all old gems... and when I
run my cucumber "rake features" command I got the following:

c:/ruby/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:27:in
`gem_original_require': no such file to load --
spec/expectations/differs/default (MissingSourceFile)
        from c:/ruby/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:27:in
`polyglot_original_require'
        from
c:/ruby/lib/ruby/gems/1.8/gems/polyglot-0.2.5/lib/polyglot.rb:54:in
`require'
        from
c:/ruby/lib/ruby/gems/1.8/gems/activesupport-2.3.2/lib/active_support/dependencies.rb:156:in
`require'
        from
c:/ruby/lib/ruby/gems/1.8/gems/activesupport-2.3.2/lib/active_support/dependencies.rb:521:in
`new_constants_in'
        from
c:/ruby/lib/ruby/gems/1.8/gems/activesupport-2.3.2/lib/active_support/dependencies.rb:156:in
`require'
        from
c:/ruby/lib/ruby/gems/1.8/gems/cucumber-0.2.3/bin/../lib/cucumber/cli/main.rb:92:in
`enable_diffing'
        from
c:/ruby/lib/ruby/gems/1.8/gems/cucumber-0.2.3/bin/../lib/cucumber/cli/main.rb:35:in
`execute!'
        from
c:/ruby/lib/ruby/gems/1.8/gems/cucumber-0.2.3/bin/../lib/cucumber/cli/main.rb:20:in
`execute'
        from c:/ruby/lib/ruby/gems/1.8/gems/cucumber-0.2.3/bin/cucumber:6
rake aborted!
Command failed with status (1): [c:/ruby/bin/ruby -I
"c:/ruby/lib/ruby/gems...]


Any thoughts on fixing this as ‘gem install spec’ gives me : “ERROR:  could
not find gem spec locally or in a repository”,

Andre

-- 
View this message in context: http://www.nabble.com/%28MissingSourceFile%29-no-such-file-to-load----spec-expectations-differs-default-tp23035747p23035747.html
Sent from the rspec-users mailing list archive at Nabble.com.



More information about the rspec-users mailing list