[rspec-users] Problem with colorized output in cygwin on Vista (was: RSpec Formats with Strange Characters)

Bernie btelles at gmail.com
Sun Apr 5 13:51:44 EDT 2009

This was a tough one, although I still don't have color on autospec
(only have color when running specs manually ), AND I forgot exactly
how the problem was solved, but hopefully this will get you in the
right direction.

1. here are two gems that may help:
       gem install term-ansicolor
       gem install win32console
       and then for some reason I aded the following to my /cygdrive/c/
Users/<myusername>/irbrc file (I'm not sure if this is necessary for
running specs, but you may want to try it).
        require 'win32console'

2. finally installing and using the RXVT shell instead may have solved
the problem (again, I compleletely forgot)
    You can find it in the "Shells" section of the CYGWIN installer.
Here are the three checks I used:
    rxvt: VT102...
    rxvt-unicode-X: An improved...
    rxvt-unicode-common: An improved....

3. If you're doing a lot of work on IRB, you may want to also install
Wirble and add a few more lines to your irbrc:
    require 'wirble'

Wellp, hope this at least got you in the right direction...if you find
out how to colorize autospec, could you let me know?

On Apr 5, 12:23 pm, David Chelimsky <dchelim... at gmail.com> wrote:
> Changing the name of this to hopefully catch the eye of other
> Vista/cygwin/rspec users.
> On Sun, Apr 5, 2009 at 9:45 AM, Brandon Olivares
> <programmer2... at gmail.com> wrote:
> >> -----Original Message-----
> >> From: rspec-users-boun... at rubyforge.org [mailto:rspec-users-
> >> boun... at rubyforge.org] On Behalf Of aslak hellesoy
> >> Sent: Sunday, April 05, 2009 6:50 AM
> >> To: rspec-users
> >> Subject: Re: [rspec-users] RSpec Formats with Strange Characters
> >> Please describe your environment. OS, various versions etc.
> > Ruby 1.8.7, RSpec 1.2.2, Cygwin on Windows Vista.
> Those characters are for coloring the output. I'm running XP in
> Parallels w/ ruby 1.8.7 and cygwin and I get colored output rather
> than seeing those characters. I'm guessing Vista is different :)
> Anybody else running Vista that knows how to get this to work?
> > Thanks,
> > Brandon
> > _______________________________________________
> > rspec-users mailing list
> > rspec-us... at rubyforge.org
> >http://rubyforge.org/mailman/listinfo/rspec-users
> _______________________________________________
> rspec-users mailing list
> rspec-us... at rubyforge.orghttp://rubyforge.org/mailman/listinfo/rspec-users

More information about the rspec-users mailing list