[rspec-users] Upgraded to 2.1 and 1.1.4 from 2.0 and 1.1.3, no output from 'rake spec'

David Chelimsky dchelimsky at gmail.com
Wed Sep 24 08:46:51 EDT 2008


On Wed, Aug 27, 2008 at 9:56 AM, Joe Van Dyk <joe at pinkpucker.net> wrote:
> No, I don't get any output from that, or by using the spec command.
> Nothing got overwritten.

Joe - trying to get caught up w/ my mail :)

Did you ever get this resolved?

>
> Joe
>
> On Mon, Aug 25, 2008 at 4:44 PM, Matt Wynne <matt at mattwynne.net> wrote:
>> What happens if you run an individual spec file with ruby from the command
>> line?
>>
>> e.g.
>>        ruby spec/models/blog_post_spec.rb
>>
>> Do you get any more clues from that?
>>
>> Also bear in mind that script/generate rspec will have overwritten your
>> spec/spec_helper.rb file, where you might have put custom stuff for your
>> project (loading fixtures etc) - do a diff against the version you had
>> before you upgraded and see if there's anything obvious missing from the new
>> one.
>>
>> cheers,
>> Matt
>> ----
>> http://blog.mattwynne.net
>> http://songkick.com
>>
>> In case you wondered: The opinions expressed in this email are my own and do
>> not necessarily reflect the views of any former, current or future employers
>> of mine.
>>
>>
>>
>> On 26 Aug 2008, at 00:29, Joe Van Dyk wrote:
>>
>>> Any ideas?
>>>
>>> On Sat, Aug 23, 2008 at 10:11 AM, Joe Van Dyk <joe at pinkpucker.net> wrote:
>>>>
>>>> $ rake spec --trace
>>>> (in /Users/joe/projects/tanga)
>>>> ** Invoke spec (first_time)
>>>> ** Invoke db:test:prepare (first_time)
>>>> ** Invoke db:abort_if_pending_migrations (first_time)
>>>> ** Invoke environment (first_time)
>>>> ** Execute environment
>>>> ** Execute db:abort_if_pending_migrations
>>>> ** Execute db:test:prepare
>>>> ** Invoke db:test:clone_structure (first_time)
>>>> ** Invoke db:structure:dump (first_time)
>>>> ** Invoke environment
>>>> ** Execute db:structure:dump
>>>> ** Invoke db:test:purge (first_time)
>>>> ** Invoke environment
>>>> ** Execute db:test:purge
>>>> ** Execute db:test:clone_structure
>>>> ** Execute spec
>>>>
>>>> $
>>>>
>>>>
>>>> Running "script/spec /path/to/spec" also doesn't give output.
>>>>
>>>> Any ideas?  I ran "script/generate rspec" and let it overwrite
>>>> everything.
>>>>
>>> _______________________________________________
>>> rspec-users mailing list
>>> rspec-users at rubyforge.org
>>> http://rubyforge.org/mailman/listinfo/rspec-users
>>
>> _______________________________________________
>> rspec-users mailing list
>> rspec-users at rubyforge.org
>> http://rubyforge.org/mailman/listinfo/rspec-users
>>
> _______________________________________________
> rspec-users mailing list
> rspec-users at rubyforge.org
> http://rubyforge.org/mailman/listinfo/rspec-users
>


More information about the rspec-users mailing list