[rspec-users] RCov / RSpec segfaults on Ubuntu

Matt Wynne matt at mattwynne.net
Sat Sep 13 06:36:33 EDT 2008


Hi all,

I appreciate that this is not an RSpec question, but I wondered if  
anyone out there can offer some pointers. We're using the latest  
versions of RSpec and RCov, and ruby --version says this (on the  
Ubuntu build server):

	ruby 1.8.6 (2008-07-17 patchlevel 279) [x86_64-linux]

We're getting intermittent (yes, intermittent!) segfaults from the  
build when running code coverage.

It works on my (OS X 10.4) machine ;)

I can't see how to report bugs with RCov - the FAQ 'your question  
here'[1] doesn't offer my anywhere to type anything. It's also  
suggested elsewhere on the site that you can report issues on the  
release notes page[2], and I can see plenty of other peoples'  
feedback, but again I can't see any way to offer any of my own.

I must be missing something really obvious here - can anyone help me  
to get in touch with whatever RCov 'community' exists?

Failing that - any good resources / tips for working around these  
segfault issues - any 'no go areas' we can just avoid in our specs? I  
noticed, for example, that one of our projects consistently  
segfaulted on this line:
	
	/vendor/plugins/rspec/lib/spec/mocks/message_expectation.rb:41:  
[BUG] Segmentation fault

Any pointers greatly appreciated.

cheers,
Matt

[1]http://eigenclass.org/hiki/rcov+FAQ#l11
[2]http://eigenclass.org/hiki/rcov-0.8.1

----
http://blog.mattwynne.net
http://songkick.com

In case you wondered: The opinions expressed in this email are my own  
and do not necessarily reflect the views of any former, current or  
future employers of mine.



-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://rubyforge.org/pipermail/rspec-users/attachments/20080913/d96950c2/attachment.html>


More information about the rspec-users mailing list