[rspec-users] Cucumber and fixtures/FixtureReplacement

Tim Glen tim at pivotib.com
Tue Sep 9 13:22:29 EDT 2008

Hey guys,

I'd never used RSpec Stories before, so I decided to follow the  
apparent direction of the wind and just jump right into cucumber. I'm  
dabbling with/using Cucumber and really like it. Good job, aslak!

Where i'm struggling right now is using either fixtures or a model  
factory methodology like the FixtureReplacement. In both cases, I'm  
not seeing anything getting loaded into the database.

I have some legacy fixtures that I'm willing to let go of, but I kind  
of assumed that they would work for now. When I run my Features, I'm  
not seeing anything whatsoever loaded into the db.

When I use FixtureReplacement (http://replacefixtures.rubyforge.org/),  
i'm getting errors that the methods aren't defined. I've added a  
"config.include FixtureReplacement" to my spec_helper but that didn't  
seem to make any difference. Then I tried adding "include  
FixtureReplacement" into my Steps Before block, but that doesn't work  

any thoughts?
Tim Glen
Rails 2.0.2
RSpec 1.1.4

More information about the rspec-users mailing list