[rspec-users] Fwd: spec_server not working...

Mark Wilden mark at mwilden.com
Fri Oct 31 17:47:25 EDT 2008


On Fri, Oct 31, 2008 at 2:34 PM, Matt Darby <matt at matt-darby.com> wrote:

> I can't seem to get spec_server to work correctly (I've never used it
> before, so maybe I'm missing something?)
>

Try running 'spec' (presuming it's in your path). I had problems running
'script/spec' with version 1.1.9. I don't know if that will help, but it's
worth a shot.

For my money, spec_server is the most useful part of Rails programming that
very few people use (TextMate is the opposite).

///ark


>
> I start up spec_server as prescribed:
> mdarby at macbook:~/Documents/apps/CCW: rake spec:server:start
> (in /Users/mdarby/Documents/Apps/CCW)
> Starting up spec server.
> Loading Rails environment
> Ready
> spec_server launched. (PID: 31387)
>
>
> Then I try to run a spec and it times out after about thirty seconds:
> mdarby at macbook:~/Documents/apps/CCW: ./script/spec --drb
> spec/models/job_spec.rb
> No server is running
>
> ^C/usr/local/lib/ruby/1.8/drb/drb.rb:566:in `read': Interrupt
>         from /usr/local/lib/ruby/1.8/drb/drb.rb:566:in `load'
>         from /usr/local/lib/ruby/1.8/drb/drb.rb:632:in `recv_reply'
>         from /usr/local/lib/ruby/1.8/drb/drb.rb:923:in `recv_reply'
>         from /usr/local/lib/ruby/1.8/drb/drb.rb:1202:in `send_message'
>         from /usr/local/lib/ruby/1.8/drb/drb.rb:1093:in `method_missing'
>         from /usr/local/lib/ruby/1.8/drb/drb.rb:1177:in `open'
>         from /usr/local/lib/ruby/1.8/drb/drb.rb:1092:in `method_missing'
>         from /usr/local/lib/ruby/1.8/drb/drb.rb:1110:in `with_friend'
>         from /usr/local/lib/ruby/1.8/drb/drb.rb:1091:in `method_missing'
>         from
> /usr/local/lib/ruby/gems/1.8/gems/rspec-1.1.11/lib/spec/runner/drb_command_line.rb:13:in
> `run'
>         from
> /usr/local/lib/ruby/gems/1.8/gems/rspec-1.1.11/lib/spec/runner/option_parser.rb:184:in
> `parse_drb'
>         from
> /usr/local/lib/ruby/gems/1.8/gems/rspec-1.1.11/lib/spec/runner/option_parser.rb:124:in
> `order!'
>         from
> /usr/local/lib/ruby/gems/1.8/gems/rspec-1.1.11/lib/spec/runner.rb:202:in
> `options'
>         from
> /usr/local/lib/ruby/gems/1.8/gems/rspec-1.1.11/lib/spec/runner/command_line.rb:8:in
> `run'
>         from ./script/spec:5
>
> Gems installed:
> rspec (1.1.11)
> rspec-rails (1.1.11)
>
> Any thoughts?
>
> Thanks!
>
>
> _______________________________________________
> rspec-users mailing list
> rspec-users at rubyforge.org
> http://rubyforge.org/mailman/listinfo/rspec-users
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://rubyforge.org/pipermail/rspec-users/attachments/20081031/0b6275b9/attachment.html>


More information about the rspec-users mailing list