[rspec-users] Help: Attempts to run specs quitting midstream

Scott Taylor mailing_lists at railsnewbie.com
Thu Oct 30 21:23:31 EDT 2008


On Oct 30, 2008, at 8:21 PM, Evan Dorn wrote:

> I am having a very frustrating problem running specs on my current
> project.  When I run tests en masse with "rake spec" or with autotest,
> it frequently quits without completing all the tests.   It also
> sometimes runs the tests in multiple batches, giving more than one
> result line for a single batch of tests.
>
> For example, on my current project (which has in total 524  
> examples), it
> currently runs a batch of 31 examples (with 0 failures), outputs a
> result line, then runs a batch of 131 examples (with 3 failures),
> outputs a result line, then reports "rake aborted"  with  "command  
> <long
> command here> failed".
>
> If I put --reverse in spec.opts, it quits in a different place after a
> different number of specs.
>
> If I run with --trace, it reports that the final complaint is in
> spectask.rb line 177.   This is a line that looks for error results  
> when
> it executes the command with system().
>
> As far as I can tell, there is no way for me to know which spec file  
> was
> actually executing when it quit.  Very frustrating.
>
> System information:
>   OS X 10.5.5
>   Ruby 1.8.6
>   rspec 1.1.11
>
>
> Below is an shell transcript.    If this had run successfully, there
> would be 524 examples run, instead of 31 and then 131.    The  
> particular
> numbers change as I edit my files.
>
> Thanks for any help, I'm tearing my hair out here.

I'd file this bug report at lighthouse:

http://rspec.lighthouseapp.com/dashboard

Scott



More information about the rspec-users mailing list