[rspec-users] RSpec 1.1.9 on JRuby

Ashley Moran ashley.moran at patchspace.co.uk
Thu Oct 23 16:41:07 EDT 2008


On Oct 23, 2008, at 2:58 pm, David Chelimsky wrote:

> For rspec-1.1.9 you have to be on rubygems 1.3 to avoid those
> dependencies (as they are developer deps and I just used hoe to create
> the gemspec, which makes them normal deps for rubygems <= 1.2).
>
> I'll make sure that dep is not there for the next rspec release, but
> in the mean time, upgrading to rubygems 1.3 and reinstalling rspec
> will solve your problem. That assumes that there is a jgem-1.3. If
> not, you can probably do this:
>
> git clone git://github.com/dchelimsky/rspec.git
> git co 1.1.9
>
> Then modify rspec.gemspec to eliminate the dependency and build the  
> gem locally:
>
> jgem build rspec.gemspec
> jgem install pkg/rspec-1.1.9.gem
>
> HTH,
> David


Hi David

Thanks for the explanation.  I can live with 1.1.8 in the meantime: I  
only need it for Cucumber+Celerity, so I won't be doing anything  
complex in JRuby.  I assume the next JRuby release will include  
RubyGems 1.3.

Cheers
Ashley


-- 
http://www.patchspace.co.uk/
http://aviewfromafar.net/



More information about the rspec-users mailing list