[rspec-users] RSpec 1.1.9 on JRuby

Ashley Moran ashley.moran at patchspace.co.uk
Thu Oct 23 08:43:16 EDT 2008


Hi

Can you use RSpec 1.1.9 on JRuby?  Now it depends on spicycode-rcov, I  
can't install it:

# jgem install rspec --development
Building native extensions.  This could take a while...
ERROR:  Error installing rspec:
	ERROR: Failed to build gem native extension.

/opt/local/share/java/jruby/bin/jruby extconf.rb install rspec -- 
development


Gem files will remain installed in /opt/local/share/java/jruby/lib/ 
ruby/gems/1.8/gems/spicycode-rcov-0.8.1.3.0 for inspection.
Results logged to /opt/local/share/java/jruby/lib/ruby/gems/1.8/gems/ 
spicycode-rcov-0.8.1.3.0/ext/rcovrt/gem_make.out

Thanks
Ashley

-- 
http://www.patchspace.co.uk/
http://aviewfromafar.net/





More information about the rspec-users mailing list