[rspec-users] autotest with a non-rspec project

Jon Dahl lists at ruby-forum.com
Wed Oct 15 18:24:18 EDT 2008


I'm getting the same error - I'm using Test::Unit with Shoulda for this 
particular project, and can't autotest because it is trying to load 
autotest/rails_rspec.

David Chelimsky wrote:
> The only reason that I know of that this would be happening would be
> that there are both a spec directory in your app and the rspec gem
> somewhere on your path.

I don't have a spec directory in the app, except perhaps in a plugin; 
and I tried uninstalling the RSpec gem. But it is still trying to load 
autotest/rails_rspec, and failing.

> 
> We've introduced an autospec command since the last release just to
> avoid this conflict. So one thing you might try doing is cloning the
> git repo, building and installing the gem from source (see
> http://github.com/dchelimsky/rspec/wikis).
> 

Are you talking about autospec as a replacement for autotest (which 
wouldn't seem to help the Test::Unit autotest problem), or a rewrite of 
autotest/Zentest that includes separate commands for autospec 
(RSpec-only) and autotest (Test::Unit only)?

Thanks!
-- 
Posted via http://www.ruby-forum.com/.


More information about the rspec-users mailing list