[rspec-users] cucumber question - uninitialized constant creating object in model

Tim Walker walketim at gmail.com
Tue Nov 25 09:13:52 EST 2008


Thanks very much for this information guys. I got side-tracked with a
dev issue and hope to have time to work on this this morning. No doubt
my env.rb is jacked. What part of the install creates that?  I see it
in the downloaded project but not in my development project after
installing cucumber. Should this like in config and is it specific to
cucumber? Many thanks again as I get up to speed.

Also, any chance to be a Beta read of the RSpec book?

Sincerely,

Tim
On Mon, Nov 24, 2008 at 8:50 AM, aslak hellesoy
<aslak.hellesoy at gmail.com> wrote:
>
>
> On Sun, Nov 23, 2008 at 6:50 PM, Tim Walker <walketim at gmail.com> wrote:
>>
>> Sorry if this is a really basic question. Scanned the past several
>> months archives, didn't see it.
>>
>> When I am running "cucumber features"
>>
>> I get the error:
>>
>>  "uninitialized constant Thing (NameError)"
>>
>> With step code being executed as...
>>
>> Given /^a thing consisting of "L1" $/ do
>>   Thing.new
>> end
>>
>> I understand that this probably a basic question but it's like
>> cucumber isn't loading my rails environment.
>
> What version/revision of cucumber?
> What's in your features directory?
> What's the contents of your env.rb file?
> What's the full stack trace?
>
> Aslak
>
>>
>> Many thanks in advance.
>>
>> T
>> _______________________________________________
>> rspec-users mailing list
>> rspec-users at rubyforge.org
>> http://rubyforge.org/mailman/listinfo/rspec-users
>
>
> _______________________________________________
> rspec-users mailing list
> rspec-users at rubyforge.org
> http://rubyforge.org/mailman/listinfo/rspec-users
>


More information about the rspec-users mailing list