[rspec-users] Cucumber autotest load error between 0.1.8 and 0.1.9

Harry Love harry at harrylove.org
Tue Nov 18 10:37:23 EST 2008


On Tue, Nov 18, 2008 at 7:56 AM, Peter Jaros <peter.a.jaros at gmail.com> wrote:
> Could you explain what doesn't work when you run autotest?  Or, I
> suppose, what it *does* do? :)
>
> Also, does `script/cucumber features` work?

I originally ran 'script/generate cucumber' under 0.1.8. The
script/cucumber executable created by that process looks in
vendor/plugins for the gem and doesn't include the rescue from
LoadError if it's not found.

Yesterday I upgraded to 0.1.9. I was not aware that I needed to re-run
'script/generate cucumber' again for my app. Doing so solved the
problem because it updated the script/cucumber executable which now
includes the rescue clause.

'script/cucumber features' works now, as does autotest. Before the
update I was running 'rake features' and 'cucumber features' manually,
both of which point to the gem, so I never received an error.

I only noticed the problem when I tried to use autotest because it
calls script/cucumber which, until I regenerated the cucumber code,
only looked in vendor/plugins for the gem. So a LoadError exception
was being thrown.

Harry


More information about the rspec-users mailing list