[rspec-users] .with(:anything) issue

Luis Lavena luislavena at gmail.com
Thu Nov 13 08:43:55 EST 2008

On Thu, Nov 13, 2008 at 10:38 AM, Emmanuel Pirsch <emmanuel at pirsch.org> wrote:
> Hi,
> I'm using a expectation like this :
> repository.should_receive(:add_gem).with("test.txt", :anything)
> When I run my spec, it fails with the following message :
> Spec::Mocks::MockExpectationError in 'MiniGemServer should add a new gem to
> the repository after it has been uploaded'
> #<MiniGemServer::Repository:0xb11164> expected :add_gem with ("test.txt",
> :anything) but received it with ("test.txt",
> "C:/DOCUME~1/xyzuser/LOCALS~1/Temp/RackMultipart20081113-8392-1vodbzf-0")
> Shouldn't it be working? The first argument is the same and I don't really
> care about the second one as long as it is there. I also tried to replace
> :anything with :string and got the same error.
> Any idea why I get this?

Did you tried "anything" (not a symbol) instead?

Luis Lavena
Human beings, who are almost unique in having the ability to learn from
the experience of others, are also remarkable for their apparent
disinclination to do so.
Douglas Adams

More information about the rspec-users mailing list