[rspec-users] Cucumber Scaffolds

James B. Byrne byrnejb at harte-lyne.ca
Wed Nov 12 13:59:49 EST 2008


On Wed, November 12, 2008 12:27, James B. Byrne wrote:
>
> The features test now shows this:
>
> $ rake features
...
>   Scenario: Register a new entity                                      #
> features/manage_entities.feature:7
>     Given I am on the new entity page                                  #
> features/steps/entity_steps.rb:1
>       wrong number of arguments (3 for 1) (ActionView::TemplateError)
>       On line #10 of app/views/entities/new.html.erb
>
>       7: <% form_for(@entity) do |f| %>
>       8:
>       9:   <%= render  :partial  => 'entities/entity_header',
>       10:               :object   => @entity -%>
>       11:
>       12:   <p>
>       13:   <%= f.submit "Create" -%>
>
>       vendor/plugins/rspec-rails/lib/spec/rails/extensions/action_view/base.rb:13:in
> `render_partial'
>       vendor/plugins/rspec-rails/lib/spec/rails/extensions/action_view/base.rb:13:in
> `render_partial'
>
...
>
> # steps/entity_steps.rb
> Given /I am on the new entity page/ do
>   visits "/entities/new"
> end

Any hints on what I am doing wrong here?  Should I be asking this question
on a webrat list?  Is there one? I cannot find it.


-- 
***          E-Mail is NOT a SECURE channel          ***
James B. Byrne                mailto:ByrneJB at Harte-Lyne.ca
Harte & Lyne Limited          http://www.harte-lyne.ca
9 Brockley Drive              vox: +1 905 561 1241
Hamilton, Ontario             fax: +1 905 561 0757
Canada  L8E 3C3



More information about the rspec-users mailing list