[rspec-users] rake features and cucumber feature/name not producing same result

Mikel Lindsaar raasdnil at gmail.com
Wed Nov 5 17:52:00 EST 2008


On Thu, Nov 6, 2008 at 2:53 AM, Joseph Wilk <josephwilk at joesniff.co.uk>wrote:

> I'm getting expected: "1"
>>                         got: "0"
>> on a simple should change(Model, :count).by(1)
>>
>> It follows the specific model around as well.  If I change order of the
>> fit table or not (the fit table has 20 rows of different models all being
>> exercised the same way, they are part of a replication tool that copies a
>> database).  The only time it passes is when I run the feature independently.
>>
>>  Are you running using Webrat or Selenium/Watir?


Yes!  Running webrat, latest trunk version (as of yesterday anyway).  Though
this feature doesn't use it specifically, webrat is loaded with a require
line in the features/steps/env.rb file.

-- 
http://lindsaar.net/
Rails, RSpec and Life blog....
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://rubyforge.org/pipermail/rspec-users/attachments/20081106/9e37ff80/attachment.html>


More information about the rspec-users mailing list