[rspec-users] Problem running "rake spec" with Workling and Starling

Tadatoshi Takahashi tadatoshi.mailinglist at gmail.com
Sun Nov 2 12:07:26 EST 2008


I installed Starling and Workling and set them up.
Then when I tried to run "rake spec", it halts with a message
"config/starling.yml configured to connect to starling on localhost:22122
for this environment. could not connect to starling on this host:port. pass
starling the port with -p flag when starting it. If you don't want to use
Starling at all, then explicitly set Workling::Remote.dispatcher (see README
for an example)"

But the port 22122 is set for development in config/starling.yml.

I tried to execute rake spec ENV["RAILS_ENV"] = "test"
But the same result.

Does anybody know the reason why this happens and how to resolve it?

Thank you.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://rubyforge.org/pipermail/rspec-users/attachments/20081102/d7e8eaf8/attachment.html>

More information about the rspec-users mailing list