[rspec-users] Cucumber changes between 0.1.8 and edge

Barry Mitchelson barry.mitchelson at gmail.com
Sat Nov 1 08:51:02 EDT 2008


On Sat, Nov 1, 2008 at 5:02 AM, Pau Cor <lists at ruby-forum.com> wrote:

> When I run `rake features` after adding cucumber v0.1.8 to my rails app
> (as a plugin), I get success. But when I upgrade to edge, I get this
> error:
>
> "
>
> |/home/paul/sc/ror/cebu_heroku/vendor/plugins/cucumber/bin/../lib/cucumber/formatters/pretty_formatter.rb:205:in
> `ljust': no implicit conversion from nil to integer (TypeError)"
>
> Full message here: http://pastie.org/305371
>
> Here is my feature file: http://pastie.org/305372
>
> And here are my step definitions: http://pastie.org/305373
>
> I tried looking through
> http://github.com/aslakhellesoy/cucumber/tree/master/History.txt but I
> didn't see anything that would help me find the difference.
>
> So what changed (and was it meant to)?
>

This sounds like the issue I had here
http://rspec.lighthouseapp.com/projects/16211/tickets/60-patch-next_column_index-not-resetting-after-large-tables.
Is there a feature running before this one with a scenario table with
at
least 2 more columns than the one in the failing feature?
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://rubyforge.org/pipermail/rspec-users/attachments/20081101/137119b5/attachment.html>


More information about the rspec-users mailing list