[rspec-users] Permission error when installing rspec

marcio marcio.rails at gmail.com
Wed May 28 14:45:57 EDT 2008


Hi Pat! Thanks a lot I realized that was not rspec the problem, i
changed my linux distro and  i forgot to update my gem , i had the 0.9
version! Now the rspec and all the others gem works perfectly. thanks
a lot.

On 28 mayo, 02:47, "Pat Maddox" <perg... at gmail.com> wrote:
> On Tue, May 27, 2008 at 3:33 PM, marcio <marcio.ra... at gmail.com> wrote:
> > hello from here! i'm new in rspec and i have a problem while
> > installing rspec 1.1.4 gem:
>
> > marcio at marcio-work:~$ gem install rspec
> > Bulk updating Gem source index for:http://gems.rubyforge.org
> > ERROR:  While executing gem ... (Errno::EACCES)
> >   Permission denied - /var/lib/gems/1.8/cache/rspec-1.1.4.gem
>
> > I did it with sudo and there was no problem, but when i attemp to use
> > rspec (spec [RUBYFILE]), the sys does not find the gem! So i
> > uninstalled it and now i'm having this permission problem. Anyone
> > could help to me?
>
> > Thanks anyway
> > _______________________________________________
> > rspec-users mailing list
> > rspec-us... at rubyforge.org
> >http://rubyforge.org/mailman/listinfo/rspec-users
>
> I doubt this has anything to do with rspec.  What happens when you try
> to install other gems?
>
> Pat
> _______________________________________________
> rspec-users mailing list
> rspec-us... at rubyforge.orghttp://rubyforge.org/mailman/listinfo/rspec-users


More information about the rspec-users mailing list