[rspec-users] rspec fails at first run -- no such file to load -- spec/rails

Larry Kluger rspec at kluger.com
Mon May 19 20:01:35 EDT 2008


Hi,

I newly downloaded rspec, rspec_on_rails and ran the command
ruby script/generate rspec
from the instructions   http://rspec.info/documentation/rails/install.html

I then created the directories in spec: 
  controllers, fixtures, helpers, models, views

I then created the file spec/models/user_spec.rb  as a spec for my model User.
(Is the convention to name the model's spec     user.rb  ?? ) The docs give both examples on different pages of the wiki.

Anyhow, my problem:
I run rake spec
and get 

/usr/local/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:27:in `gem_original_require': no such file to load -- spec/rails (MissingSourceFile)

The file /spec/spec_helper.rb contains the line
require 'spec/rails'

Using the response to a similar q/a I found on the net, I also tried
   ruby script/spec spec
Same result.

Pointers would be most appreciated.

Thanks,

Larry

ps. I URGE the powers-that-be to update the installation instructions. This type of problem dramatically slows down adoption of an otherwise great projec 
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://rubyforge.org/pipermail/rspec-users/attachments/20080519/4b4f9af0/attachment.html>


More information about the rspec-users mailing list