[rspec-users] Problems running RSpec from w/in TextMate

David Schmidt davids at tower-mt.com
Sat May 10 12:59:24 EDT 2008

I also had problems with running RSpec from within TextMate where  
sometimes it would work and sometimes it would fail repeatedly and  
finally found my problem.  At the bottom of the TextMate window look  
at the status line in the second box to see what type of file TextMate  
has the file set as.  If it's not "RSpec" then click on it and change  
it to "RSpec" and try running the test again.

If it's not set to RSpec then it may be trying to just run the file as  
a Ruby script, which doesn't work from within TextMate.  When using  
the RSpec TextMate bundle the window that opens when you run Command-R  
should be titled "Run Examples".  If it just says "Run" then the file  
type probably isn't set to RSpec.

Hope that helps!

David Schmidt

On May 10, 2008, at 8:30 AM, Wayne Molina wrote:

> Hello everyone, I'm new to RSpec, and pretty much Ruby in general.   
> I am
> trying to run RSpec from within TextMate to get the nice-looking GUI
> that lists my specs and whatnot.  It runs fine from the command line,
> but when I run it from TextMate, I get the following error (I am  
> working
> with a Rails application):
> [...]
> I don't know how to fix this.. I have tried to search Google but I  
> can't
> find anything that deals with it or how to fix it.  I am using RSpec
> 1.1.3 - this is confirmed via gem list rspec.  I've also installed the
> latest RSpec tmbundle, just to be on the safe side.
> It's not a big deal, since as I said it works from the command line,  
> but
> I would rather not switch out of TextMate so I'm really hoping that
> someone can give me some pointers on how to fix this error, since my  
> own
> searches are turning up empty.
> Thanks to anyone who can offer some advice!

More information about the rspec-users mailing list