[rspec-users] Problems running RSpec from w/in TextMate

David Chelimsky dchelimsky at gmail.com
Sat May 10 11:41:07 EDT 2008


On May 10, 2008, at 10:30 AM, Wayne Molina wrote:

> Hello everyone, I'm new to RSpec, and pretty much Ruby in general.   
> I am
> trying to run RSpec from within TextMate to get the nice-looking GUI
> that lists my specs and whatnot.  It runs fine from the command line,
> but when I run it from TextMate, I get the following error (I am  
> working
> with a Rails application):
>
>
> RubyMate r8136 running Ruby r1.8.6 (/usr/local/bin/ruby)
>>>> event_spec.rb
>
> /Users/waynemolina/work/liberty_truth/vendor/plugins/rspec/lib/spec/ 
> runner/options.rb:195:in
> `files_to_load': File or directory not found: [, (RuntimeError)
>   from
> /Users/waynemolina/work/liberty_truth/vendor/plugins/rspec/lib/spec/ 
> runner/options.rb:187:in
> `each'
>   from
> /Users/waynemolina/work/liberty_truth/vendor/plugins/rspec/lib/spec/ 
> runner/options.rb:187:in
> `files_to_load'
>   from
> /Users/waynemolina/work/liberty_truth/vendor/plugins/rspec/lib/spec/ 
> runner/options.rb:85:in
> `run_examples'
>   from
> /Users/waynemolina/work/liberty_truth/vendor/plugins/rspec/lib/ 
> spec.rb:20:in
> `run'
>   from
> /Users/waynemolina/work/liberty_truth/vendor/plugins/rspec/lib/spec/ 
> runner.rb:192:in
> `register_at_exit_hook'
>   from
> /Users/waynemolina/work/liberty_truth/spec/models/event_spec.rb:75
>
> RuntimeError: File or directory not found: [,
>
> I don't know how to fix this.. I have tried to search Google but I  
> can't
> find anything that deals with it or how to fix it.  I am using RSpec
> 1.1.3 - this is confirmed via gem list rspec.  I've also installed the
> latest RSpec tmbundle, just to be on the safe side.

Actually, that is on the dangerous side. If you are using rspec 1.1.3,  
you should use the TextMate bundle from the same release. Try grabbing  
that and see if it works.

http://rspec.rubyforge.org/svn/tags/REL_1_1_3/RSpec.tmbundle/

Cheers,
David



>
>
> It's not a big deal, since as I said it works from the command line,  
> but
> I would rather not switch out of TextMate so I'm really hoping that
> someone can give me some pointers on how to fix this error, since my  
> own
> searches are turning up empty.
>
> Thanks to anyone who can offer some advice!
> -- 
> Posted via http://www.ruby-forum.com/.
> _______________________________________________
> rspec-users mailing list
> rspec-users at rubyforge.org
> http://rubyforge.org/mailman/listinfo/rspec-users



More information about the rspec-users mailing list