[rspec-users] before_save model callback rspec testing

Yi Wen hayafirst at gmail.com
Tue Jun 24 09:24:56 EDT 2008


That's because you executed the same creation code into the
script/console, which has nothing to do with RSpec, and still get the
same error message, right?

Yi

On Tue, Jun 24, 2008 at 2:56 AM, Csongor Bartus <lists at ruby-forum.com> wrote:
> Yi Wen wrote:
>> Well, at least now we know this is nothing to do with RSpec. My
>> suggestion is that you comment out the code which will be executed
>> during a creation, bit by bit in User (such as before_save) and try to
>> create a user. In this way you can pinpoint where the problem is.
>
> Thanks a lot Yi Wen,
>
> Now I'll find out easier where the bug lies ...
> But how did you realized the bug is not in RSpec but in the code?
>
>
> --
> Posted via http://www.ruby-forum.com/.
> _______________________________________________
> rspec-users mailing list
> rspec-users at rubyforge.org
> http://rubyforge.org/mailman/listinfo/rspec-users
>


More information about the rspec-users mailing list