[rspec-users] rspec-users Digest, Vol 24, Issue 20

James B. Byrne byrnejb at harte-lyne.ca
Fri Jun 13 13:04:10 EDT 2008



>
> Message: 4
> Date: Fri, 13 Jun 2008 11:47:22 -0500
> From: David Chelimsky <dchelimsky at gmail.com>
> Subject: Re: [rspec-users] rspec and rspec-rails install hell
> To: rspec-users <rspec-users at rubyforge.org>
> Message-ID: <EFE63242-19E9-42C5-AACD-16E239A9023B at gmail.com>
> Content-Type: text/plain; charset=US-ASCII; format=flowed; delsp=yes
>
> On Jun 13, 2008, at 11:27 AM, James B. Byrne wrote:
>

>> Here is the problem.  If RSpec gem is installed then I get the
>> rspec-rails / rspec version mismatch.  If I remove the RSpec gem
>> then the rake tasks will not run.
>
> For some reason rails is not finding rspec in vendor/plugins. Don't
> know why.
>
> To get things running, you can just go into rspec-rails/lib/spec/rails/
> version.rb and comment the code that's complaining about the version
> mismatch. The risk is fairly low at this point that you're going to
> have any trouble.
>
> If you don't want to do that - try checking out the 1.1.4 version of
> spec-rails, so starting clean (no rspec anywhere) you would do this:
>
> gem install rspec
> cd vendor/plugins
> git clone git://github.com/dchelimsky/rspec-rails.git
> cd rspec-rails
> git checkout 1.1.4
>
> Now you should have the same versions of the rspec gem and rspec-rails
> plugin.
>
> Let us know if that works.

Yes, it did.  Thank you.

Regards,

-- 
***          E-Mail is NOT a SECURE channel          ***
James B. Byrne                mailto:ByrneJB at Harte-Lyne.ca
Harte & Lyne Limited          http://www.harte-lyne.ca
9 Brockley Drive              vox: +1 905 561 1241
Hamilton, Ontario             fax: +1 905 561 0757
Canada  L8E 3C3



More information about the rspec-users mailing list