[rspec-users] Why has the --color gone from my life?

David Chelimsky dchelimsky at gmail.com
Tue Jul 8 15:43:38 EDT 2008


On Jul 8, 2008, at 2:09 PM, Bart Zonneveld wrote:

> On 10 jun 2008, at 07:05, Mikel Lindsaar wrote:
>
>> This was fixed up updating to trunk:
>>
>> 3b76fda..befd422  master     -> origin/master
>
> Looks like I have the same problem now. Created a new rails app  
> (2.1.0), and using the install instructions on the github wiki,  
> leaves me with an autotest (ZenTest version 3.10.0) running autotest/ 
> rails instead of autotest/rails_rspec as some of my older projects do.
> When I copy vendor/plugins/rspec-rails/lib/autotest/rails_rspec.rb  
> to ~/.autotest, autotest runs with:

Why are you copying that there?

Try doing this:

cd vendor/plugins/rspec
rake gem
rake install_gem
rake clobber
cd ../../../
autospec

Since you're using edge, autospec is the new command to run autotest  
with rspec.


>
>
> /opt/local/bin/ruby -I.:lib:test -rtest/unit -e "%w[spec/controllers/ 
> foos_routing_spec.rb spec/views/foos/index.html.erb_spec.rb spec/ 
> helpers/foos_helper_spec.rb spec/models/foo_spec.rb spec/views/foos/ 
> new.html.erb_spec.rb spec/views/foos/show.html.erb_spec.rb spec/ 
> views/foos/edit.html.erb_spec.rb spec/controllers/ 
> foos_controller_spec.rb].each { |f| require f }" | unit_diff -u
>
> giving me grey specs.
>
> So, without an .autotest, nothing at all happens. Running autotest - 
> v gives, among all the .git files even Dunno! app/controllers/ 
> application.rb!
> With rspec-rails' autotest, it runs with -r test/unit.
>
> Weird stuff, hopefully someone makes sense of this al.
> bartz
>
>
>> On Sat, Jun 7, 2008 at 2:09 AM, David Chelimsky  
>> <dchelimsky at gmail.com> wrote:
>> On Jun 6, 2008, at 10:57 AM, Juanma Cervera wrote:
>>
>> This was an error, but I thought it was corrected by D. Chelimsky.
>>
>> That is correct - at least temporarily - there is a conflict with  
>> how rspec and autotest output to a terminal that makes it  
>> challenging for rspec to color code terminal output while not  
>> including the color code chars in html output.
>>
>> If anybody is interested in helping to solve that, check out http://rspec.lighthouseapp.com/projects/5645/tickets/413 
>> .
>>
>> Cheers,
>> David
>>
>> _______________________________________________
>> rspec-users mailing list
>> rspec-users at rubyforge.org
>> http://rubyforge.org/mailman/listinfo/rspec-users
>>
>> _______________________________________________
>> rspec-users mailing list
>> rspec-users at rubyforge.org
>> http://rubyforge.org/mailman/listinfo/rspec-users
>
> _______________________________________________
> rspec-users mailing list
> rspec-users at rubyforge.org
> http://rubyforge.org/mailman/listinfo/rspec-users



More information about the rspec-users mailing list