[rspec-users] Rspec 1.1.2 on Windows

BenFyvie ben.fyvie at champsoftware.com
Mon Jan 21 15:53:50 EST 2008


I am using Rspec 1.1.2 on Windows XP SP2

I am receiving the following error when I run 'rake spec' from a brand new
project:
C:/SVN_Projects/rspec/vendor/plugins/rspec/lib/spec/runner/options.rb:107:in
`colour=': You must gem install win32console to use colour on Windows
(RuntimeError)

I have the win32console gem installed and the error still occurs.  It seems
that the require statement in options.rb line 105 is throwing an exception
and I am not sure why.  I have even gone to the extent of replacing
'Win32/Console/ANSI' with the absolute path to the ANSI file and still no
luck.  When I run the require statement in a console everything works fine
and dandy.

Now if I remove the --colour option from the spec.opts file then it doesn't
need the win32console gem; however, I then receive this error:
C:/ruby/lib/ruby/gems/1.8/gems/activesupport-1.3.1/lib/active_support/dependencies.rb:100:in
`const_missing': uninitialized constant Spec::Rails (NameError)

I do have the rspec_on_rails plugin installed.  Can anyone offer me any
suggestions on how to troubleshoot this issue? Thanks in advance!
-- 
View this message in context: http://www.nabble.com/Rspec-1.1.2-on-Windows-tp15006297p15006297.html
Sent from the rspec-users mailing list archive at Nabble.com.



More information about the rspec-users mailing list