[rspec-users] no method error

David Chelimsky dchelimsky at gmail.com
Sun Jan 20 21:59:02 EST 2008


On Jan 20, 2008 7:52 PM, G-man <gregor007 at gmail.com> wrote:
> I've set up my tests, and when I run the whole thing, I get this for my
> views:
>
> 3)
>  NoMethodError in '/chapters/new.html.erb should render new form'
>  undefined method `process_clean_up_fixtures' for
> #<Spec::Rails::Example::ViewExampleGroupController:0x447ddcc>
>  c:/rails/rails_apps/tracker/spec/views/chapters/new.html.erb_spec.rb:15
> script/spec:4:

Can we see some code? What do the spec and the view look like?

> Also, no word on my autotest question?
>
> c:\rails\rails_apps\tracker>autotest
> loading autotest/rails_rspec
> from
> C:\Rails\rails_apps\tracker\vendor\plugins\rspec_on_rails\lib\autotest\rails_rspec.rb
>  C:\Rails\ruby\bin\ruby -rrubygems -e "require 'redgreen'"  -S script/spec
> -O spec/spec.opts  spec/controllers/chapters_routing_spec.rb
>  invalid option: -O
> Test::Unit automatic runner.
>  Usage: -e [options] [-- untouched arguments]

There was another thread about this just a day or two ago. Not sure
what exactly the problem is, but there seems to be conflict with
redgreen and the changes to autotest in ZenTest-3.8.0. Get rid of that
and it should work.

>
> The script/spec spec/models, etc tests run just fine, however ... it's only
> the autotest and these view things that are hanging up ...
>
> Thanks,
>
> G
>
> --
> Happiness is not to have what you want,
> But to want what you have!
> Gregor Jovanovich 714 651 9969 ...
> Father to some, Friend to all


More information about the rspec-users mailing list