[rspec-users] Rspec 1.1.3 +ZenTest 3.9.1= rspec tests not found

Terry Shuttleworth lists at ruby-forum.com
Fri Feb 8 17:46:59 EST 2008


Hi there

Have upgraded to Rspec 1.1.3 and ZenTest 3.9.1 and have --force
re-installed rspec plugin in the relevant place, but am getting the
following when I run rake spec:autotest

spec --diff unified test/test_helper.rb

and not

spec --diff unified <humungous list of lovingly crafted rspec tests>

Have tried looking in the plugin codes and in the ZenTest gem code, but
I can't find what I need to change to get it to look for my rspec tests
rather than look at test/test_helper.rb

Have spent the past couple of hours googling around to find an answer,
but to no avail.

Can anyone please point me in the right direction ?

Thanks in advance !

Terry

(I know about the "script/spec" edit that I have to make so that the
"spec --diff unified" command works. Have reinstalled rspec this so many
times tonight that I can't remember if I did it in the last
incarnation!)
-- 
Posted via http://www.ruby-forum.com/.


More information about the rspec-users mailing list