[rspec-users] Shared examples not reloading in spec_server

David Chelimsky dchelimsky at gmail.com
Thu Feb 7 11:01:19 EST 2008


On Feb 7, 2008 9:39 AM, Charles Grindel <cgrindel at yahoo.com> wrote:
>
> I am currently running RSpec 1.1.3 with ZenTest 3.9.1 on Windows XP.  I have
> noticed that shared examples are not being reloaded by spec_server when they
> have been updated.  Below is a simple example that reproduces the problem.
> The example code and output is at the location below.
>
>
> http://pastie.caboo.se/148688
>
> I have confirmed that non-shared examples are being reloaded by spec_server.
> So, here are my questions.
>
> 1. Has anyone else noticed this behavior?
>
> 2. Does anyone know how I can force spec_server to reload the shared
> examples?
>
> 3. If this smells like a bug, can someone point me to instructions for
> filing a bug?

Sounds like a problem with your autotest configuration, not with
spec_server. Try it without spec server to verify that is correct.

If it's that autotest isn't loading them, you just need to add a
mapping in .autotest. Read the ZenTest docs for more info and/or check
out my blog post on this:
http://blog.davidchelimsky.net/articles/2008/01/15/rspec-1-1-2-and-zentest-3-8-0.

If you try that and you still think it's an rspec bug, file a ticket
at http://rspec.lighthouseapp.com.

Cheers,
David

>
> Thanks,
> Chuck
>
> _______________________________________________
> rspec-users mailing list
> rspec-users at rubyforge.org
> http://rubyforge.org/mailman/listinfo/rspec-users
>


More information about the rspec-users mailing list